Bon, j'ai un linux, et un archos 15 vision (cf. http://www.archos.com/products/mp3_p...try=us&lang=en).

Je n'ai pas eu de problème pour monter le périphérique les premières fois, à la main ou via automount.

J'ai enlevé le câble USB avant d'avoir fait un sync (pour flusher les données que j'avais écrites dans le répertoire MUSIC), et depuis... c'est le drame. Automount ne fait plus rien, un mount à la main m'envoie bouler également :


poz@light:~$ sudo mount -t vfat /dev/sdb /media/archos/
mount: wrong fs type, bad option, bad superblock on /dev/sdb,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Le dmesg me dit ça :

[4207914.003376] usb 1-6: USB disconnect, address 19
[4207917.320095] usb 1-6: new high speed USB device using ehci_hcd and address 20
[4207917.453416] usb 1-6: configuration #1 chosen from 1 choice
[4207917.455888] scsi16 : SCSI emulation for USB Mass Storage devices
[4207917.457527] usb-storage: device found at 20
[4207917.457541] usb-storage: waiting for device to settle before scanning
[4207922.460481] usb-storage: device scan complete
[4207922.461104] scsi 16:0:0:0: Direct-Access Archos USB MP3 1.00 PQ: 0 ANSI: 0
[4207922.469011] sd 16:0:0:0: Attached scsi generic sg1 type 0
[4207922.475335] sd 16:0:0:0: [sdb] 7958528 512-byte logical blocks: (4.07 GB/3.79 GiB)
[4207922.475962] sd 16:0:0:0: [sdb] Write Protect is off
[4207922.475975] sd 16:0:0:0: [sdb] Mode Sense: 03 00 00 00
[4207922.475983] sd 16:0:0:0: [sdb] Assuming drive cache: write through
[4207922.479601] sd 16:0:0:0: [sdb] Assuming drive cache: write through
[4207922.479622] sdb: unknown partition table
[4207922.484336] sd 16:0:0:0: [sdb] Assuming drive cache: write through
[4207922.484353] sd 16:0:0:0: [sdb] Attached SCSI removable disk
[4207949.024684] FAT: invalid media value (0x82)
[4207949.024696] VFS: Can't find a valid FAT filesystem on dev sdb.
[4209481.513667] FAT: invalid media value (0x82)
[4209481.513684] VFS: Can't find a valid FAT filesystem on dev sdb.

Et un simple fsck m'envoie bouler :

poz@light:~$ sudo fsck.vfat /dev/sdb
dosfsck 3.0.7, 24 Dec 2009, FAT32, LFN
Logical sector size (33265 bytes) is not a multiple of the physical sector size.

Je vous avoue que je suis assez mécontent. D'autant que j'ai déjà eu le pseudo OS sur cet Archos planté (il a fallu reseter le matériel). J'ai l'impression que c'est un peu l'arnaque, ce produit. Bref, il est pas cher, donc ça compense un peu. Si vous avez une idée de comment fixer mon problème, je suis preneur.

Ah oui précision : je ne peux plus rien faire en standalone non plus, ie. je me paie des "Warning: No file!" dès que je veux jouer un morceau ou quoi que ce soit. La classe quoi.