logo

Firmware Froyo : précisions d’Archos

vendredi 3/12/2010 par

Commentaires 41 commentaires

Suite à la publication du premier firmware Gen8 sous Froyo, de nombreux commentaires ont rapidement fleuri sur notre forum pour évoquer différents problèmes.
Comme nous l’avions ensuite sous-entendu, toutes vos remarques ont été remontées à la R&D d’Archos et nous avons aujourd’hui la possibilité de vous proposer le résultat de leur analyse :

CPU :
Nous avons calé le CPU ARM Cortex A8 à un maximum de 800MHz par défaut, dans le but d’optimisation la durée de vie de la batterie. Tous les produits d’Archos utilisent de telles réductions de fréquence (par exemple lors de la lecture de MP3, la fréquence du CPU tombe à 300MHz). La fréquence de 1 GHz est actuellement utilisée pour un certain nombre de tâches comme la navigation internet.
Avec l’application de benchmark Quadrant, nous atteignons approximativement la même performance sous le firmware Eclair 1.0.84 et sous le firmware Froyo 2.0.54.
Notez cependant qu’il existe un bug avec les résultats affichés par cette application pour le firmware actuel, pour lequel l’évaluation de la vitesse du CPU est erronée. Ce problème a été corrigé en interne et nous atteignons désormais un sore de plus de 1300 points avec l’Archos 43IT.

Wi-Fi :
Nous avons identifié deux problèmes avec le Wi-Fi :
- Il est impossible de se connecter à des points d’accès en utilisant un canal supérieur à 11. Contournement possible : configurez les points d’accès avec des canaux inférieurs. Ce problème est déjà corrigé en interne et nous le publierons dans la prochaine mise à jour du firmware, très proche.
- Sur certains produits, le Wi-Fi plante parfois avec l’encryptage WPA2/AES. Contournement : utilisez un mode d’encryptage différent sur le point d’accès si possible. Nous travaillons avec notre fournisseur de chipset pour identifier une solution.

Flash :
Nous avons une configuration spécifique pour le plugin flash, qui active l’accélération matérielle pour optimiser le décodage vidéo et qui ne peut être rendu public tant que la certification d’Adobe n’est pas finalisée. Tous les benchmarks actuellement réalisés avec d’autres plugin flash aboutiront à de pauvres performances qui ne reflèteront pas l’aptitude de notre plateforme.


Texte original :

CPU :
We have set the ARM cortex A8 CPU to a maximum of 800MHz by default in order to optimize the battery life. All Archos products are using frequency scaling as a means to prolong battery life (e.g. when listening to MP3, CPU speed goes down to 300MHz). 1GHz is currently used for certain tasks like Internet browsing.
We are achieving approximately the same performance between eclair 1.0.84 and froyo 2.0.54 firmwares using Quadrant benchmarking software.
Note that there is an issue with Quadrant benchmarking software on our current firmware resulting in a false result regarding CPU speed evaluation. It has been fixed internally and we reach now a score of more than 1300 for the Archos43it.

Wi-Fi :
We have identified 2 issues with Wi-Fi :
- Problem : it is impossible to connect on access points using channels above 11. Workaround : configure the access point to use another channel. Problem already solved internally and will be published in a firmware update very soon.
- Problem : on some devices wifi gets stuck sometimes with WPA2/AES encryption. Workaround : use a different encryption mode on the access point if possible. We are working with our chipset provider to find a solution.

Flash :
We have a specific flash plugin configuration that enables hardware acceleration for optimized video decoding that cannot be made public until Adobe certification is completed. All benchmarks currently conducted with other flash plugins will result in poor performance that will not reflect our platform capability.


Partagez cet article sur les réseaux sociaux: + FB
[ télécharger l'article au format PDF]

Firmware Froyo : précisions d’Archos

Les commentaires pour les anciens articles sont désormais fermés.

41 commentaires


  • - le 3 décembre 2010 à 15h56min

    Avec tous ces problèmes et surtout l’impossibilité de trouver la 101 en magasin, je crois que je vais attendre début 2011 et l’arrivée des premières tablettes sous Gingerbread... Vraiment dommage pour Archos.

  • Okeydokey - le 3 décembre 2010 à 15h58min

    Archos qui communique ? Voilà qui fait plaisir...

  • gabrie1 - le 3 décembre 2010 à 16h06min

    Ils communiquent en Anglais(ça ok) mais sans traduire en français (!)...

    "il existe un bug avec les résultats affichés par cette application pour le firmware actuel"
    Moui je doute.

  • marko - le 3 décembre 2010 à 16h19min

    Et le problème des sous-titres qui ne s’affichent plus, ils en font quoi ???

  • Little_iki - le 3 décembre 2010 à 17h02min

    @Marko

    A bon cela fonctionne de mon coté, mais je précise des str ... Des sous-titre sont inclus dans les MKV ?

  • - le 3 décembre 2010 à 17h21min

    Bravo Archos pour les régressions !
    Mon WiFi est en WPA2/AES sur le canal 13 (car tous mes voisins squattent les autres canaux).
    Il est hors de question que je change mes paramètres WiFi (qui fonctionnaient d’ailleurs très sous Eclair 2.1).
    Bon, je vais ENCORE attendre le prochain firmware !
    Espérons qu’il arrive plus vite cette fois-ci !

  • Thocan - le 3 décembre 2010 à 17h26min

    A vous lire, je pense que ça motive à mort Archos de continuer à communiquer auprès de la communauté dans le futur... Vraiment... :-/

  • Little_iki - le 3 décembre 2010 à 17h31min

    Sinon je croyais de la fréquence était de 1ghz tout le temps ... On m’ aurait menti a l’insu de mon plein gré ....

    Donc vivement la sortie de la version 2.2.09 pour corriger les légers bugs et anomalies sans compter les optimisations !

    Mais en attendant ... Je croise les doigts pas de soucis de wifi ... Mais des petits plantages a répétitions ... Du player et de launcher pro !

    Sans compter que l’historique des films vus ou en cours disparaît lui aussi !

    Mais ce n’est que du soft, prions ensemble mes frères ...
     ;-)

  • Alibaskins - le 3 décembre 2010 à 17h35min

    Merci pour la remontée d’info.
    Un ptit widget qui permet de désactiver le mode d’économie d’énergie serait surement le bienvenue comme certain le disent sur le forum.

    Perso j’attends une version optimisée aux ptits oignons comme la version 2.1 que j’utilise actuellement et avec laquelle je n’ai aucun souci à part le flash qui ne me dérange pas plus que ça :)

    Merci Archoslounge pour la remontée d’infos auprès d’archos ;)

    Edit : Pi ba merci Archos, y en a qui sont contents de vos produits et de votre boulot :)

  • switcheremac - le 3 décembre 2010 à 17h47min

    Bizarre en anglais pour une boite réputée française , ils ont dû envoyer les doléances au service après vente marocain ou indien !

    La première réponse ( fréquence ) est plutôt intéressante et sensée !

  • Diiok - le 3 décembre 2010 à 17h54min

    Justement, cela n’a que du bon que l’archos réduise les perfs du proc, si vous écoutez de la musique, ça sert a rien que le système tourne à fond pour consommer de la batterie alors que 400 Mhz suffisent amplement à lire de la musique. Vous regardez un WMV en 720p ,là il monte à 1Ghz(c’est logique et normal !). Les ordinateurs font la même chose. Moi qui est proc 4 cœurs 3ghz, au moment ou je vous écrit, et bien il tourne à 1 ghz. Et puis la mise à jour est toute récente. ils ont optimiser le lancement des applications, le bureau va plus vite... Il y a encore quelques bug à corriger, c’est tout. Puis Archos à prévu de lâcher une autre MAJ dans quelques temps !!
    Patience les amis !!!

  • Thocan - le 3 décembre 2010 à 18h03min

    @switcheremac : ils écrivent en anglais comme la grande majorité des boites de ce type qui bossent sur l’international et communiquent vers l’international... Rien de surprenant à cela.

  • Zarkenciel - le 3 décembre 2010 à 18h05min

    C’est très bien de leur part de communiquer. Au moins on ne se sent pas abandonné.

    J’espère que chez Archos ils sont conscients des problèmes de réactivité générale et de l’écran tactile... ils n’en parlent pas, pourtant j’ai lu dans les forums que nous sommes plusieurs à être touchés.

  • DuelMan - le 3 décembre 2010 à 18h15min

    Merci beaucoup Archos !!
    Je conseille à tout le monde de rester en éclair et d’attendre la prochaine version qui seras débuggée !!

  • shunzen - le 3 décembre 2010 à 18h25min

    Personnellement, en 2.1 ou 2.2 je reste toujours autant amoureux de mon 43it !!! :) Certains jeux du market fonctionnent sous 2.2 alors qu’ils ne passaient pas sous 2.1, le WIFI se connecte plus rapidement et je ne vois pas vraiment de ralentissement... Que du bon et le meilleur reste à venir !!

  • Thocan - le 3 décembre 2010 à 19h14min

    @Zarkenciel : ils sont informés des soucis de ralentissements chez certains mais ce problème-là ne semble pas - à ma connaissance - avoir été reproduit. Chez moi, comme chez beaucoup d’autres, pareil : l’interface sous Froyo tourne au moins aussi bien qu’avant.

    Mon sentiment est qu’il doit y avoir un critère bien particulier dans l’environnement (peut-être une application ?) qui génère ce ralentissement. Mais pour l’instant, rien d’identifié.

  • - le 3 décembre 2010 à 19h48min

    Pour ceux qui cherche des tablette du coté de Lyon, Leclerc Meyzieu en a recu 2 pieces 16 Go

  • wumps13 - le 3 décembre 2010 à 20h30min

    Perso je suis passé en 2,2 sur mon A70 et je suis très content ! parfois ça bug un peu mais lors des prochaines mise à jour ça sera ok.

    Pour les premières tablet sous gingerbread faudra attendre minimum février vu que gingerbread n’est même pas sortie !! en attendant j’aurais mon archos depuis 3 mois !! pourquoi pas attendre la 3,0 aussi ou la 4,0 elle sera encore mieux....

  • marko - le 3 décembre 2010 à 21h36min

    Les sous-titres srt mis à part avec un avi par exemple ou inclus dans un mkv, ne fonctionnent pas. Alors que avec Rockplayer ça fonctionne, et sous 2.1 il n’y avait pas de problème.
    Le lecteur est aussi moins fluide, certaines vidéo ralentissent contrairement sous la 2.1.

  • marko - le 3 décembre 2010 à 21h37min

    Et sur archosfans il y a les mêmes retours.

  • little_iki - le 4 décembre 2010 à 11h22min

    @ marko
    alors je dois avoir de la chance ...

    Sinon installation dela 2.2 en repartant de zero ... et donc re-installation de tous les apk et du hack du market !

    Et pour l’ instant les avi avec str passent bien avec le lecteur d’origne qi bug de temps en temps .... perte des films lus perte pour la reprise d’un film ... ou plantage tout court ... enfin 9/10 il marche !

    Et le tout sans avoir a recoder lesmkv en 720p ... font moins de 4.5 Go ... chouette ;-)

    C’est le gros avantage par rapport a la pomme en en dene pad passer par ce p’tain d’itunes

  • - le 4 décembre 2010 à 14h38min

    Comment dans ces conditions avoir envie d’acheter un Archos ?
    je cours acheter un Ipad, même avec un système fermé et tout le reste, il y a une chose importante chez Apple !! ça marche !!!!
    Terminé, jusque là je n’achetais que Archos depuis les premiers, maintenant cela ressemble à un gros foutage de gueule !
    pour ceux qui s’y accrochent, cela tient plus de la dévotion que de la défense de bon produit !!
    bye bye Archos !

  • - le 4 décembre 2010 à 14h39min

    Faut voir pour les mkv, j’en ai un paquet qui passent tres mal en gros ça rame. Apres pour les subs ça depend de la hauteur de frame de la video.

  • Thocan - le 4 décembre 2010 à 15h35min

    A monsieur l’anonyme merci pour ce gros troll qui n’était pas vraiment nécessaire

  • Diiok - le 4 décembre 2010 à 15h41min

    A tout les coups c’est Steve Jobs qui a utilisé un traducteur pour lâcher son troll ici ! :)
    Ok,ok je sors --- > xD

  • lolo33 - le 4 décembre 2010 à 17h00min

    Je ne vois pas en quoi c’est un troll. Je ne suis pas anonyme et j’en ai dejà parlé sur le forum de problemes de sous-titres que je n’avais pas avant, il y en a aussi sur arkosfan.

  • switcheremac - le 4 décembre 2010 à 17h16min

    lolo 33 tu n’as jamais connu les premiers Macs Intel et certains débuts de nouveaux Mac OS !

    Le pire que j’ai connu c’est la passage de processeurs PPC à X86 ... il a fallu attendre la première MAJ pour ne pas " perdre " de temps en temps la souris ! Il fallait la débrancher et la rebrancher ! Ce n’était pas un drame , cependant pendant 3 semaines je me suis cru sous Windows ! lol ...

  • Thocan - le 4 décembre 2010 à 17h46min

    Le mec qui hurle à la mort pour un simple problème de sous-titrage, j’appelle ça du troll bien inutile.

  • speeed - le 4 décembre 2010 à 19h43min

    Moi je ne regrette qu une chose
    jaurrais du acheter un ipad

  • - le 4 décembre 2010 à 21h11min

    La c’est toi qui troll Thocan c’est pire que les fanboy Apple. Ou tu vois que je hurle à la mort ???
    Je précise juste que depuis la mise à jour les sous-tires fonctionnent mal et le lecteur patine. Ce n’est peut être pas primordial pour TOI mais pour d’autres si !
    Je ne pense pas que la partie multimédia ne soit pas importante pour Archos. Et faire remonter le problème ne me parait pas inutile.

  • wumps13 - le 4 décembre 2010 à 21h14min

    Perso je ne regrette nullement l’ipad et pourtant je suis gros fans apple : TRop lourd, trop gros, galère les videos non compatible, pas de carte sd, pas de hdmi , webcam non et multitaches iosx pas terrible sans parler du prix celui d’un laptop deja puissant..

    Reste la qualite de finition, la fluidité du soft et le store mieux mais ça ne compense pas... On comprends alors la puissance du marketing apple.

  • - le 4 décembre 2010 à 21h25min

    lol "Reste la qualite de finition, la fluidité du soft et le store mieux"
    Pour une grande majorité ça fait la différence, et ça se comprend. Les tablettes Android il faut mettre un peu les mains dans le moteur et ce n’est pas encore assez mature. Mais je pense qu’on va voir des trucs bien sympa dans l’avenir avec Honeycomb et des tablettes plus puissantes.

  • Thocan - le 5 décembre 2010 à 01h28min

    Remonter le fait qu’il existe des problèmes avec les sous-titres (d’ailleurs déjà corrigé sur la bêta dont je dispose), c’est pertinent et utile. Rajouter dans ses phrases des menaces de "je revends mon Archos et je cours m’acheter un iPad", j’appelle ça du troll.

  • lolo33 - le 5 décembre 2010 à 01h45min

    Et ou tu as vu ça dans mon poste ??? Faut arreter la parano.

  • vax - le 5 décembre 2010 à 11h40min

    Ces remarques sont les bienvenus pour ceux que ça concerne :-))
    Mais il me semble , à la lecture de post sur le fofo , que le soucis majeur , vient de la fonction de mise à jour de la tablette .
    J’ai effectué cette mise à jour par cette appli intégré , le comportement de la tablette c’est dégradé !
    Aprés une réinstallation , par le biais du recovery mode , j’ai retrouvé une tablette , plus véloce et trés agréable à utiliser !
    Un tuto , svp !

  • - le 5 décembre 2010 à 12h52min

    Tiens je vais resonner comme toi, debrouille toi.

  • Maohi - le 6 décembre 2010 à 08h54min

    Ils ne parlent même pas du problème réseau SMB qui marque tout le temps "Dossier vide" sous Windows 7 (alors que ça marchait mieux (mais pas à 100%) sous la 2.1) ??

    J’ai pris le 70IT 8 Go en me disant que tout passerait par le wifi/réseau, et si ça, ça ne marche plus, beh... j’ai un peu les boules quand même ! :(

  • p’tit Seb - le 6 décembre 2010 à 10h32min

    Le problème du "Dossier Vide" en SMB est dû au "Windows Live ID Assistant". On peu trouver des liens en recherchant sur les incidents XMBC par exemple, où des pb similaire existe (lié au client Samba).
    N’empêche, il faudrait le corriger côté Archos, car le Live Assistant est obligatoire pour jouer aux "Games for Windows"...

  • thln - le 6 décembre 2010 à 19h30min

    Moi aussi j’ai les boules !

    J’ai le problème "/network/smb/... : "Dossier vide", et pourtant je suis sur Windows-XP !

    Par ailleurs, en utilisant "ARTRO" ou "File Expert" ca marche !

    Ils ont complètement "merder" avec cette version !

    Et en plus, on ne peut même pas revenir à la précedente version !

  • Adimante - le 8 décembre 2010 à 17h01min

    Le protocole SMB est une appli Samba sous Linux qui émule du Windows. En fait, on utilise Samba (SMB) dans les environnements hétérogènes, où un serveur Linux gère des postes-clients sous Windows. Ici, c’est la tablette Archos qui tourne sous un OS dérivé de Linux (Android). Et si, en voulant se connecter à la machine Windowss via SMB et que Windows pose problème lors de la connexion réseau de la tablette Archos, pourquoi ne pas la connecter à un réseau sous Linux ? Plus de SMB ! Plus de bug Windose et vive la liberté ! Je conseille Ubuntu, car c’est facile, mais n’importe quel installation Linux fera l’affaire.

  • Little_iki - le 12 décembre 2010 à 11h36min

    Heu ... Enfin pour attaquer mon NAS sous Linux ... Parfois cela marche d’autres pas ... Donc chercher la stabilité du soft !

    Je pensais être a l’ecart de ce bug, jusqu’à hier matin pour du streaming via le module audio en smb .... Plus de répertoire sur le nas !

    et ce matin ok .. Chouette la vie
     ;-(